This FAQ was last updated: May 13, 2015     Views: 27

Question:
What Web browser should I use for ILL (ILLIAD)?

Our answer:

A current version of Internet Explorer is recommended, however Mozilla Firefox has the functionality to process the Cascading Style Sheets used by the ILLiad software. 

Ask us Now!